Runboard.com
You're welcome.

Revhead Kev

Last blog entries

Aircon compressor replacement

February 16, 2016 at 2:58am

After 12 years the aircon compressor had finally had enough. Got the system tested when it failed to blow any bit of cool air and the compressor had failed.

Well with compressors being around $1600 from the dealer and around $1100+shipping from Amayama I decided to see if anyone in Aus either reconditioned aircon compressors or sold reconditioned ones as a swap.

Bingo !
Found a company in Rockhampton which sold reconditioned and new compressors. Sent them an enquiry and got the reply "Sorry no reconditioned compressors for your model but we have new ones for $485 shipped to Sydney"
WOW !
So I checked they were a direct bolt-on replacement with same mounting points, pipe fittings and clutch-pulley. It was.
The guy there, Steven, knows all the Xtrail models, making sure mine was a T30 and explaining it was the same compressor in the Series 1 and Series 2 but for the T31 there were 3 different compressor models.

So when the compressor arrived 2 days later I checked it with the old one and yes, exactly the same.
The aircon place fitted it no hassle, $300 for regas, new O-rings and labour.

Very happy I now have cold air and no fogging of the windows in wet weather but most importantly the greatest price around for a new aircon compressor with 12 month/20,000kms warranty :o)

Comments loading...

Update on work done

November 20, 2014 at 8:47pm

It's been a while and I should update where I am at with work on the Xtrail.

It is getting on in years (11 now) so expectedly there has been some replacements needed to keep it running.

I finished the replacement of the rear engine mount and a DIY can be found on the forum for both.

The transfer pinion rear bearing and seal was also replaced, done by a diff-rebuilding 4WD shop after I removed the transfer pinion assembly from the Xtrail. Easy enough to do after dropping the tailshaft. A DIY for this should be on the forum also.

There was the steering knuckle joint which had one axis freeze too. There is not a DIY as such for this on the forum but the thread I posted trying to determine what was the problem causing my steering problems has pics and an explaination of how to replace it.

Last to be done was replacing all 4 struts with KYB gas and both front driveshafts. DIYs for these will be on the forum soon.

Comments loading...

Front Engine Mount Replacement

April 16, 2013 at 2:02am

Found the time (and dry weather) to get the front engine mount replaced last weekend. This is the start of fixing the transfer case seal and bearings.

Easy enough to support the engine/transmission with a jack while removing the centre member 6 bolts to drop it down and replace the front engine mount. This was necessary as the engine mount bolt closest to the engine cannot be reached with a socket from above and a ring spanner does not have a long enough handle to get the force onto it required to undo the bolt from underneath.

I'll post a DIY for both the front and rear engine mount replacements, with pics, once the rear is completed.

Comments loading...

Steering problem

March 16, 2013 at 10:23pm

I have developed what can only be described as a "stiffness" in the steering.
The steering wheel starts turning stiff until a short way when it then gets loose before again getting stiff and then loose again.
Seems something in the rotation of the steering box like half-turn stiff, half-turn loose as it is not related to the steering wheel turns but is repeatable as the wheel is turned further around.

Once the trandfer is fixed I'll take it to a steering place to have them check out the bushes as a culprit as all fluids are good.

Comments loading...

Transfer bearing and seal failure

March 16, 2013 at 10:19pm

Well after being told by Nissan on the last service that the oil leak was a rocker cover seal and them not getting one for me without the whole rocker cover, I decided to look for myself. No oil down the engine anywhere.

Found the rear seal on the transfer case was leaking. Filled it up and it took almost the whole prescribed amount of fluid so it was running pretty dry. Had to go to parent's place at Christmas so with the tailshaft off, 2WD only, it made the 700km trip there and back with hardly any oil used.

So closer inspection was warranted.
Found the rear engine mount had colapsed and this was probably putting extra load on the rear bearings of the transfer with the subsequent excessive wear leading to [sign in to see URL] one Nissan for not finding this earlier.

Have all the parts and just waiting for the weather to clear up so I can get under and replace the front & rear engine mounts before having a mechanic help me with the bearings on the transfer pinion.

Missing the 4WD trips while waiting.

Comments loading...

 

Miscellaneous info

User since

Oct 20, 2006 at 1:52pm

Location

Mona Vale, Sydney, AUSTRALIA

Personal bio

2003 (Series 1) Xtrail Ti-L Auto Hi-Tech Full Exhaust/Extractors + TBS + Snorkel Superior Engineering 50mm Spacer lift + Yokohama GO12 AT's

 

Bookmarks

Private
 

Last posts

 

Friends

Friend list loading...
 

Live feed


Filter: Revhead Kev + friends Just Revhead Kev

Live feed loading...

 

Pictures

 

Go back

You are not logged in (login)